TeamSpeak Connection & Registration Issues
Incident Report for VATSIM UK
Resolved
This incident has been resolved.
Posted Nov 08, 2020 - 22:59 GMT
Identified
We are currently looking into some issues with our TeamSpeak server. This is affecting users connecting, moving between channels and/or creating new registrations via our website.
Posted Nov 08, 2020 - 22:43 GMT
This incident affected: VATSIM UK Services (TeamSpeak).